Hosted Grafana Outage (prod-us-west-0)

Incident Report for Grafana Cloud

Resolved

Engineering has released a fix and as of 22:20 UTC, customers should no longer experience any issues. At this time, we are considering this issue resolved. No further updates.
Posted Jul 03, 2025 - 22:28 UTC

Investigating

As of 21:27 UTC, we identified a DNS-related issue affecting the prod-us-west-0 cluster. This may result in a full outage of Hosted Grafana services for impacted users.

Our engineering team is actively investigating and working to resolve the issue. We will share updates as they become available.
Posted Jul 03, 2025 - 22:17 UTC
This incident affected: Grafana Cloud: Hosted Grafana (AWS US West - prod-us-west-0).