Grafana k6 Degraded Performance

Incident Report for Grafana Cloud

Resolved

This incident has been resolved.
Posted Nov 05, 2025 - 14:33 UTC

Monitoring

The services are recovering and we can confirm that majority of the tests were not impacted.
Posted Nov 05, 2025 - 10:56 UTC

Update

We are continuing to investigate this issue.
Posted Nov 05, 2025 - 09:40 UTC

Investigating

We are currently investigating multiple issues impacting Grafana k6 tests:
- Metrics for new and running test runs arriving late.
- New test runs could be getting aborted by system or timed out.
- Result Analysis page may not show any metrics.
- Requests could be timing out throughout GCk6 Plugin.
Posted Nov 05, 2025 - 08:30 UTC
This incident affected: Grafana Cloud: k6 (GCk6 App, Cloud Test Runs, Cloud Output Test Runs, Result Analysis).