Degraded Loki Query Performance

Incident Report for Grafana Cloud

Resolved

Engineering has released a fix and as of 21:25 UTC, customers should no longer experience query performance issues.

At this time, we are considering this issue resolved. No further updates.
Posted Oct 20, 2025 - 22:12 UTC

Investigating

We are currently investigating an issue affecting Loki query performance, first observed around 21:00 UTC. Users may experience slower than normal query responses or occasional timeouts when running queries.

Our engineering team is actively working to identify the root cause and restore normal performance as quickly as possible.

We will provide updates here as more information becomes available.
Posted Oct 20, 2025 - 21:47 UTC
This incident affected: Grafana Cloud: Loki (GCP US Central - prod-us-central-5).