Some Write Failures in prod-eu-west-3.

Incident Report for Grafana Cloud

Monitoring

Things have been stable, and we have a potential mitigation should this issue arise again. We are monitoring the issue in the meantime.
Posted Mar 11, 2026 - 15:51 UTC

Identified

There are ongoing intermittent elevated transient write failures. We will continue to provide additional updates as more information becomes available.
Posted Mar 11, 2026 - 01:35 UTC

Monitoring

A fix has been implemented, and we are monitoring.
Posted Mar 10, 2026 - 18:42 UTC

Investigating

We are currently investigating an issue impacting a subset of users in the prod-eu-west-3 region. Impacted users are experiencing elevated transit write failures, with no degradation to the read path.
Posted Mar 10, 2026 - 18:00 UTC
This incident affects: Grafana Cloud: Prometheus (Azure Netherlands - prod-eu-west-3: Ingestion).