Some Users Unable to Connect New Datasources with PDC

Incident Report for Grafana Cloud

Identified

We have discovered that the issue could affect customers in all regions. We have identified the issue and are working on a fix.
Posted Jul 23, 2025 - 07:48 UTC

Investigating

We are currently investigating an issue that is preventing users from connecting new datasources with PDC in the us-east-0 region.
Posted Jul 22, 2025 - 22:12 UTC
This incident affects: Grafana Cloud: Private Datasource Connect (PDC) (AWS Australia - prod-au-southeast-1, AWS Brazil - prod-sa-east-1, AWS Canada - prod-ca-east-0, AWS Germany - prod-eu-west-2, AWS India - prod-ap-south-1, AWS Japan - prod-ap-northeast-0, AWS Sweden - prod-eu-north-0, AWS US East - prod-us-east-0, AWS US West - prod-us-west-0, Azure Netherlands - prod-eu-west-3, Azure US Central - us-central2, GCP Australia - prod-au-southeast-0, AWS Singapore - prod-ap-southeast-1, GCP Belgium - prod-eu-west-0, GCP Brazil - prod-sa-east-0, GCP India - prod-ap-south-0, GCP Singapore - prod-ap-southeast-0, GCP UK - prod-gb-south-0, GCP US Central - prod-us-central-0).