Elevated Read & Write Latency for Some Cells in Prod-Us-East-0

Incident Report for Grafana Cloud

Resolved

This incident has been resolved.
Posted Nov 20, 2025 - 18:47 UTC

Monitoring

Things have recovered, and we are monitoring to ensure stability.
Posted Nov 20, 2025 - 17:47 UTC

Update

The previous post mentioned that this was occurring in some cells in prod-us-central-0. This is incorrect and is occurring in some cells in prod-us-east-0.
Posted Nov 20, 2025 - 17:23 UTC

Identified

At approximately 16:40 UTC we noticed an issue causing increased read & write latency in some prod-us-central-0 cells. At this stage we are noticing some recovery and will continue to monitor.
Posted Nov 20, 2025 - 17:12 UTC
This incident affected: Grafana Cloud: Loki (AWS US East - prod-us-east-0), Grafana Cloud: Prometheus (AWS US East - prod-us-east-0: Querying, AWS US East - prod-us-east-0: Ingestion), and Grafana Cloud: Tempo (AWS US East - prod-us-east-0: Querying).