The incident is now resolved. An error in an infrastructure change meant that the SSH endpoint for PDC in eu-west-3 region was unavailable for customers to connect to. Reverting the change fixed the issue and PDC agents were able to reconnect successfully.
Posted Aug 12, 2025 - 10:22 UTC
Monitoring
The fix was implemented and error rate has gone down. PDC looks stable and we're continue to monitoring the overall health.
Posted Aug 12, 2025 - 09:46 UTC
Identified
The issue has been identified and our team is working on rolling out a fix currently.
Posted Aug 12, 2025 - 09:41 UTC
Update
After a closer inspection, us-central2 region looks fine and isn't experiencing issues anymore.
Posted Aug 12, 2025 - 09:37 UTC
Investigating
We're currently experiencing an issue with connectivity lost for Private Datasource Connect in 2 regions: - eu-west-3; - us-central2. Our team is aware of the issue and is actively working on finding the cause.
Posted Aug 12, 2025 - 09:31 UTC
This incident affected: Grafana Cloud: Private Datasource Connect (PDC) (Azure Netherlands - prod-eu-west-3, Azure US Central - us-central2).