Elevated 429 Errors Impacting Metrics Querying Across Multiple Regions

Incident Report for Grafana Cloud

Resolved

This incident has been resolved. Thank you for your patience.
Posted Apr 20, 2026 - 14:30 UTC

Update

The issue is now confirmed to be widespread, affecting Prometheus across all regions.

Customers may continue to experience elevated 429 (rate limit) errors, particularly when querying metrics, with failures or inconsistent responses possible.

Our engineering team remains fully engaged and is actively working on mitigation and resolution efforts with the highest priority.
Posted Apr 20, 2026 - 14:21 UTC

Investigating

We are currently experiencing a major incident causing elevated 429 (rate limit) errors across multiple regions, primarily impacting metrics querying.

This is a high-priority issue, and our engineering team is actively engaged and working urgently to identify the root cause and restore full service as quickly as possible. Customers may experience widespread failures or delays when querying metrics during this time.

We understand the significant impact this may have and will continue to provide updates as more information becomes available.
Posted Apr 20, 2026 - 14:09 UTC
This incident affected: Grafana Cloud: Prometheus (AWS Australia - prod-ap-southeast-2: Querying, AWS Australia - prod-ap-southeast-2: Ingestion, AWS Brazil - prod-sa-east-1: Querying, AWS Brazil - prod-sa-east-1: Ingestion, AWS Canada - prod-ca-east-0: Querying, AWS Canada - prod-ca-east-0: Ingestion, AWS Germany - prod-eu-west-2: Querying, AWS Germany - prod-eu-west-2: Ingestion, AWS UAE - prod-me-central-1: Querying, AWS UAE - prod-me-central-1: Ingestion, AWS India - prod-ap-south-1: Querying, AWS India - prod-ap-south-1: Ingestion, AWS Japan - prod-ap-northeast-0: Querying, AWS Japan - prod-ap-northeast-0: Ingestion, AWS Singapore - prod-ap-southeast-1: Querying, AWS Singapore - prod-ap-southeast-1: Ingestion, AWS Sweden - prod-eu-north-0: Querying, AWS Sweden - prod-eu-north-0: Ingestion, AWS US East - prod-us-east-0: Querying, AWS US East - prod-us-east-0: Ingestion, AWS US West - prod-us-west-0: Querying, AWS US West - prod-us-west-0: Ingestion, Azure Netherlands - prod-eu-west-3: Querying, Azure Netherlands - prod-eu-west-3: Ingestion, AWS Ireland - prod-eu-west-6, AWS Switzerland - prod-eu-central-0, Azure US Central - us-central2: Querying, Azure US Central - us-central2: Ingestion, Azure US Central - us-central7: Ingestion, GCP Australia - prod-au-southeast-0: Querying, GCP Australia - prod-au-southeast-0: Ingestion, GCP Belgium - prod-eu-west-0: Querying, GCP Belgium - prod-eu-west-0: Ingestion, GCP Brazil - prod-sa-east-0: Querying, GCP Brazil - prod-sa-east-0: Ingestion, GCP India - prod-ap-south-0: Querying, GCP India - prod-ap-south-0: Ingestion, GCP Singapore - prod-ap-southeast-0: Querying, GCP Singapore - prod-ap-southeast-0: Ingestion, GCP UK - prod-gb-south-0: Querying, GCP UK - prod-gb-south-0: Ingestion, GCP US Central - prod-us-central-0: Querying, GCP US Central - prod-us-central-0: Ingestion, GCP US Central - prod-us-central-5: Querying, GCP US Central - prod-us-central-5: Ingestion, GCS US - cortex-prod-04: Ingestion, GCS US - cortex-prod-04: Querying, Federal Cloud - AWS US Gov West).