Service degradation on Logs Read path in AWS US West (us-west-0)

Incident Report for Grafana Cloud

Resolved

We continue to observe a continued period of stability since 19:40 UTC. At this time, we are considering this issue resolved
Posted Mar 08, 2026 - 20:31 UTC

Monitoring

Since 16:35 UTC we have experienced stability and services are recovering. We are actively monitoring and working to fully stabilize
Posted Mar 08, 2026 - 18:29 UTC

Investigating

Our engineering team is investigating issues on the read path of Loki services on AWS US West since today aroun ~13:25UTC.
These issues can cause timeouts and 5xx errors when query logs for customers on the cluster. The team is currently working to restore the service.
Posted Mar 08, 2026 - 14:17 UTC
This incident affected: Grafana Cloud: Loki (AWS US West - prod-us-west-0).