Grafana Cloud Logs - Write degradation in Azure Netherlands (eu-west-3)

Incident Report for Grafana Cloud

Identified

The impacted has been reduced to slight intermittency. We continue to work with our CSP to reach a complete resolution.
Posted Mar 03, 2026 - 22:19 UTC

Update

Since today at 11:55 UTC time we are seeing issues on the write path for Loki in cluster Azure Netherlands (eu-west-3). Impact will reflect in degradation of logs ingestion on that cluster. We are also reporting impact to Faro performance in the same region. Our engineering team is already working on restoring the service.
Posted Mar 03, 2026 - 14:15 UTC

Investigating

Since today at 11:55 UTC time we are seeing issues on the write path for Loki in cluster Azure Netherlands (eu-west-3). Impact will reflect in degradation of logs ingestion on that cluster. Our engineering team is already working on restoring the service.
Posted Mar 03, 2026 - 12:07 UTC
This incident affects: Grafana Cloud: Loki (Azure Netherlands - prod-eu-west-3) and Grafana Cloud: Faro (Azure Netherlands - prod-eu-west-3).