Permissions Issues with IRM

Incident Report for Grafana Cloud

Resolved

This incident has been resolved.
Posted Jun 05, 2026 - 21:35 UTC

Update

Continuing to monitor progress. Most customers affected should have all services restored, with a few remaining customers receiving updates as the rollout finishes out. Thanks again for your patience.
Posted Jun 05, 2026 - 20:10 UTC

Update

A fix has been released to prod and rolling out across the fleet for IRM, restoring access to affected customers. Thanks for your patience through this work. We're continuing to monitor to confirm we've returned to a steady state.
Posted Jun 05, 2026 - 19:34 UTC

Update

We've identified an earlier regression in one of our recent code changes that was affecting resolution of our previous fix. We're deploying this change now and applying a hot fix in the interim to restore access quickly
Posted Jun 05, 2026 - 18:40 UTC

Monitoring

A fix is being deployed now, and we are monitoring the progress.
Posted Jun 05, 2026 - 18:00 UTC

Identified

We've identified an issue with RBAC, and are working on a fix to restore permission services for those affected.
Posted Jun 05, 2026 - 17:14 UTC

Update

Our engineering team is still investigating this issue. We do not have any new information to share at this time, but will continue to provide timely updates.
Posted Jun 05, 2026 - 16:52 UTC

Investigating

We are currently investigating an issue impacting permissions for IRM. As a result, users are not currently getting paged. We will provide updates as they become available.
Posted Jun 05, 2026 - 16:11 UTC
This incident affected: Incident Management and Response (IRM).