Metrics Drilldown Issues

Incident Report for Grafana Cloud

Resolved

This incident has been resolved.
Posted Jun 18, 2025 - 18:14 UTC

Monitoring

A fix is currently being rolled out, and we are monitoring the results
Posted Jun 18, 2025 - 15:48 UTC

Investigating

We are currently investigating an issue with Metrics Drilldown. Customers may encounter an "App not found" error during this time.
Posted Jun 18, 2025 - 14:16 UTC