Cloudwatch Datasource Outage

Incident Report for Grafana Cloud

Resolved

This incident has been resolved. Thank you for your patience.
Posted Apr 23, 2026 - 20:01 UTC

Monitoring

We’ve implemented a fix and are monitoring the results to confirm the issue is fully resolved. Services may start to recover during this time.
Posted Apr 23, 2026 - 14:39 UTC

Investigating

We’re currently investigating an issue affecting Cloudwatch datasources. Our team is actively working to identify the cause. Thank you for your patience.
Posted Apr 23, 2026 - 14:26 UTC
This incident affected: Grafana Cloud: Hosted Grafana (GCP US Central - prod-us-central-0).