PDC Degraded performance

Incident Report for Grafana Cloud

Resolved

This incident has been resolved. Thank you for your patience.
Posted Jul 09, 2026 - 19:54 UTC

Monitoring

We are now seeing recovery of PDC traffic to the affected customers. Our team will continue to monitor across shifts.
Posted Jul 09, 2026 - 17:52 UTC

Identified

We are continuing to see disruptions across multiple deployments, ranging from degraded performance to full outages for some customers.

Additional resources have been engaged to mitigate this issue. We will post updates as they become available.
Posted Jul 09, 2026 - 16:08 UTC

Update

We are continuing to monitor for any further issues.
Posted Jul 09, 2026 - 14:44 UTC

Update

We are seeing recovery in some deployments, while others not just yet. We are continuing to monitor this incident.
Posted Jul 09, 2026 - 14:10 UTC

Monitoring

A fix has been applied and we are seeing recovery. We will continue to monitor this.
Posted Jul 09, 2026 - 13:04 UTC

Update

We are still currently investigating the issue.
Posted Jul 09, 2026 - 12:36 UTC

Investigating

We are currently facing performance degradation on PDC service hosted on Multiple clusters. Our Engineering Team is currently working on fixing the issue, we do apologize for any inconvenience.
Posted Jul 09, 2026 - 11:37 UTC
This incident affected: Private Datasource Connect (PDC) (AWS Australia - prod-au-southeast-1, AWS Germany - prod-eu-west-2, AWS Singapore - prod-ap-southeast-1, AWS US East - prod-us-east-0, GCP US Central - prod-us-central-0) and Grafana (AWS Germany - prod-eu-west-4).