Grafana Cloud Logs - Write degradation in Azure Netherlands (eu-west-3)

Incident Report for Grafana Cloud

Update

We are also reporting impact to Faro performance in the same region. We are continuing to investigate this issue.
Posted Mar 11, 2026 - 09:13 UTC

Investigating

We are seeing issues on the write path for Loki in cluster Azure Netherlands (eu-west-3). Impact will reflect in degradation of logs ingestion on that cluster. Our engineering team is already working on restoring the service.
Posted Mar 11, 2026 - 08:31 UTC
This incident affects: Grafana Cloud: Loki (Azure Netherlands - prod-eu-west-3) and Grafana Cloud: Frontend Observability & Faro Endpoint (Azure Netherlands - prod-eu-west-3).