Grafana Cloud Metrics elevated write and rule evaluation latency in prod-eu-west-2 region.

Incident Report for Grafana Cloud

Resolved

We no longer observed any problems with our services - this incident has been resolved.
Posted Feb 12, 2026 - 14:30 UTC

Monitoring

The fix has been implemented and services are back to normal. We're currently monitoring health of the services before resolving this incident.
Posted Feb 12, 2026 - 12:50 UTC

Identified

The issue has been identified and our team is currently working on a fix.
Posted Feb 12, 2026 - 12:40 UTC

Investigating

Since 12:17 UTC, we're observing an increased latency for data ingestion and rule evaluation in Grafana Cloud Metrics, prod-eu-west-2 region. We're currently investigating the issue.
Posted Feb 12, 2026 - 12:33 UTC
This incident affected: Grafana Cloud: Prometheus (AWS Germany - prod-eu-west-2: Ingestion).