Degraded k6 cloud UI performance

Incident Report for Grafana Cloud

Resolved

This incident has been resolved. Thank you for your patience.
Posted Jun 18, 2026 - 16:21 UTC

Update

We are continuing to monitor for any further issues.
Posted Jun 18, 2026 - 14:04 UTC

Monitoring

The root cause of the issue has been identified and a fix has been successfully deployed. We are observing widespread improvements across all systems. Our team is currently monitoring the environment to ensure performance remains stable.
Posted Jun 18, 2026 - 13:15 UTC

Update

We are continuing to investigate this issue.
Posted Jun 18, 2026 - 11:45 UTC

Investigating

We’re currently investigating an issue resulting in degraded k6 cloud UI performance and API response time. Our team is actively working to rectify this issue.
Posted Jun 18, 2026 - 11:25 UTC
This incident affected: Performance and Load Testing (GCk6 App, Cloud Test Runs, Test Scheduling).