Tempo Write Latency

Incident Report for Grafana Cloud

Resolved

We continue to observe a continued period of recovery. At this time, we are considering this issue resolved. No further updates.
Posted Aug 08, 2025 - 21:14 UTC

Monitoring

Engineering has released a fix and as of 19:40 UTC, customers should no longer experience degraded performance. We will continue to monitor for recurrence and provide updates accordingly.
Posted Aug 08, 2025 - 19:42 UTC

Identified

We are currently experiencing elevated write latency for Tempo in the prod-eu-west-2 region. The issue began at approximately 17:55 UTC. Our engineering team has identified the underlying cause and is actively working on a fix.

We will provide updates as soon as more information is available.
Posted Aug 08, 2025 - 18:32 UTC
This incident affected: Grafana Cloud: Tempo (AWS Germany - prod-eu-west-2: Ingestion).