A new iOS mobile app version (v2.39.5) has been released, which includes a fix for this issue. We are monitoring the rollout and its impact to ensure the issue has been fully resolved. If you continue to experience any problems after updating to the latest version, please let us know.
Posted Jul 11, 2026 - 03:58 UTC
Identified
A fix has been submitted for review and will be released as Grafana Mobile v2.39.5 once it is approved.
If your app is currently on v2.39.3, we recommend not upgrading to v2.39.4 and instead waiting for v2.39.5 to become available.
Users who have already been signed out by this issue can log back into the app and continue using it.
We will provide another update once v2.39.5 is available.
Posted Jul 10, 2026 - 22:17 UTC
Update
Our investigation has narrowed the impact to version 2.39.4 of the Grafana mobile app on iOS. Users should avoid upgrading to this version until an updated release is available.
As a precaution, we also recommend ensuring you have alternative notification methods configured (such as SMS, email, or phone calls) if you rely on mobile push notifications for alerting.
We are actively working on a resolution and will provide another update as soon as more information is available.
Posted Jul 10, 2026 - 20:37 UTC
Investigating
We are aware of an issue in the latest mobile app release that is causing some users to be signed out and asked to log in again.
We have reproduced the behavior and are investigating and working on a fix. We will share another update as soon as we have more information.
Posted Jul 10, 2026 - 20:27 UTC
This incident affects: Incident Management and Response (IRM).