K6 Sporadic DNS Issues

Incident Report for Grafana Cloud

Update

Our engineering team has deployed a fix and we are currently monitoring the behaviour of the system until full resolution.
Posted Apr 14, 2026 - 14:29 UTC

Monitoring

We’ve implemented a fix and are monitoring the results to confirm the issue is fully resolved. Services may start to recover during this time.
Posted Apr 14, 2026 - 14:29 UTC

Identified

We are having sporadic DNS issues that occasionally affect the start of cloud test runs, causing them to abort. We are currently working to resolve. The issue has been occurring since April 9.
Posted Apr 14, 2026 - 09:22 UTC
This incident affects: Grafana Cloud: k6 (Cloud Test Runs).