Grafana rulers crash-looping on prometheus

Incident Report for Grafana Cloud

Resolved

This incident has been resolved.
Posted Jul 08, 2026 - 17:23 UTC

Monitoring

We are in the process of rolling out the fix. Our engineers are monitoring the progress.
Posted Jul 08, 2026 - 14:23 UTC

Investigating

We are investigating issues with the grafana-ruler service on prod-us-east-2 and prod-us-west-0 which are causing periodic crash conditions. A code fix is currently being deployed to mitigate this
Posted Jul 08, 2026 - 12:17 UTC
This incident affected: Alerting and SLO (AWS US East - prod-us-east-0: Rule Evaluation, AWS US West - prod-us-west-0: Rule Evaluation).