Prometheus writes in prod-eu-west-3 are degraded

Incident Report for Grafana Cloud

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 24, 2026 - 09:19 UTC

Investigating

We are currently experiencing degraded writes for mimir-prod-22 in prod-eu-west-3 since 08:45Z.
Posted Mar 24, 2026 - 09:08 UTC
This incident affects: Grafana Cloud: Prometheus (Azure Netherlands - prod-eu-west-3: Ingestion).