Connectivity issues for Azure PrivateLink endpoints.

Incident Report for Grafana Cloud

Resolved

The scope of this incident was smaller than originally anticipated.

As of 16:27 UTC our engineering team merged a fix for those affected and we are considering this as resolved.
Posted Jan 14, 2026 - 20:17 UTC

Investigating

We're experiencing an issue with connectivity loss for Azure PrivateLink endpoints in all available Azure regions. The issue affects users trying to ingest Alloy data or use PDC over Azure PrivateLink. Our team is actively investigating the issue for the root cause.
Posted Jan 14, 2026 - 14:30 UTC
This incident affected: Grafana Cloud: Private Datasource Connect (PDC) (Azure Netherlands - prod-eu-west-3, Azure US Central - us-central2).