K6 Test Runs Degraded Performance

Incident Report for Grafana Cloud

Monitoring

We have applied a fix, and are monitoring the results.
Posted Jun 03, 2026 - 21:23 UTC

Investigating

We are currently investigating an issue causing k6 test runs to take longer than expected to complete, or to time out within Grafana Cloud.
Posted Jun 03, 2026 - 20:40 UTC
This incident affects: Performance and Load Testing (Cloud Test Runs, Cloud Output Test Runs).