Inconsistent threshold check results reported intermittently

Incident Report for Grafana Cloud

Resolved

This incident has been resolved.
Posted Feb 05, 2026 - 15:31 UTC

Monitoring

The issue causing the incident has been identified, and the fix has been deployed. All new test runs work consistently
Posted Feb 05, 2026 - 09:36 UTC

Update

We are continuing to work on a fix for this issue.
Posted Feb 04, 2026 - 19:57 UTC

Identified

We encountered a subtle bug which caused our test-run finalization process to read from stale threshold status because of a synchronization issue.

We have since resolved the bug, and new test runs will work properly. Impacted test runs will need to be fixed via further correction on our end. We will continue to provide updates on the progress of the fix for impacted test runs.
Posted Feb 04, 2026 - 17:20 UTC
This incident affected: Grafana Cloud: k6 (Result Analysis).