Logs latency increase within prod-eu-west-3

Incident Report for Grafana Cloud

Resolved

This incident has been resolved.
Posted Aug 04, 2026 - 13:49 UTC

Update

There's still a minor latency increase in this cell however we have identified that it is improving although not back to normal as of yet. We will continue to look into this.
Posted Aug 04, 2026 - 12:46 UTC

Investigating

We have identified minor latency increases in write endpoints within the prod-eu-west-3. Our team is currently monitoring and investigating this.
Posted Aug 04, 2026 - 10:34 UTC
This incident affected: Logs (Azure Netherlands - prod-eu-west-3).