Degraded performance of Grafana Cloud k6 test runs

Incident Report for Grafana Cloud

Resolved

Our engineering team has deployed a fix and we continue to observe a continued period of recovery.

At this time, we are considering this issue resolved. No further updates.
Posted Mar 19, 2026 - 18:11 UTC

Investigating

Some customers are seeing degraded performance and errors from certain v6 API endpoints. We are investigating the issue.
Posted Mar 19, 2026 - 11:17 UTC
This incident affected: Grafana Cloud: k6 (Cloud Test Runs).