Elevated Metric Push Failures and Latency

Incident Report for Grafana Cloud

Resolved

We continue to observe a continued period of recovery. At this time, we are considering this issue resolved. No further updates.
Posted Dec 10, 2025 - 23:05 UTC

Monitoring

We are observing a trend in improvement after implementing a fix. We will continue to monitor and update accordingly.

During our investigation, we also became aware that some alerts associated with Synthetic Monitoring checks have been failing to evaluate correctly.
Posted Dec 10, 2025 - 22:22 UTC

Identified

Our engineering team has identified a potential root cause, and a fix is being implemented.
Posted Dec 10, 2025 - 21:38 UTC

Update

Our engineering team has engaged with our Cloud Service Provider and are working together to continue to investigate this issue.
Posted Dec 10, 2025 - 20:48 UTC

Update

We are continuing to investigate this issue.
Posted Dec 10, 2025 - 19:49 UTC

Update

We have also identified that trace ingestion may also be affected. Some customers may experience elevated latency and intermittent errors when sending traces. Investigation is ongoing.
Posted Dec 10, 2025 - 19:49 UTC

Investigating

We have detected an issue causing some customers to experience failed metric pushes as well as increased latency when sending metrics. The issue was first observed at 18:30 UTC.

Our engineering team is actively investigating the root cause and working to restore normal operation as quickly as possible. We will provide further updates as more information becomes available.

Thank you for your patience while we work to resolve this issue.
Posted Dec 10, 2025 - 19:29 UTC
This incident affected: Grafana Cloud: Prometheus (GCP Belgium - prod-eu-west-0: Ingestion) and Grafana Cloud: Tempo (GCP Belgium - prod-eu-west-0: Ingestion).