Cloud Metrics -High Write Latency and Errors in prod-us-central-7

Incident Report for Grafana Cloud

Resolved

We have continued to observe stability.

This incident is now being considered as resolved. Thank you for your patience.
Posted May 08, 2026 - 22:30 UTC

Monitoring

From approximately 20:40-21:00 UTc, we experienced an issue affecting Grafana Cloud Metrics in prod-us-central-7. Affected users may have experienced high latency and/or errors during ingestion and rule evaluation.

Our team has identified the cause and mitigated. We are currently monitoring for long-term stability.
Posted May 08, 2026 - 21:16 UTC
This incident affected: Grafana Cloud: Prometheus (Azure US Central - prod-us-central-7: Ingestion).