Logs query degradation on AWS Germany (prod-eu-west-2)

Incident Report for Grafana Cloud

Resolved

The issue has been resolved.
Posted Dec 09, 2025 - 13:10 UTC

Monitoring

The query service is operational again, logs reads should be available on the cluster.
Our engineers are monitoring the health status of the service to ensure full recovery.
Posted Dec 09, 2025 - 13:06 UTC

Identified

Since today 9th, around 12:30 UTC time, we are experiencing problems on the Loki read path of cluster eu-west-2.
This translates in difficulties to query logs for customers on this cluster, and can also impact alerts and other services based on these logs.
Our engineers are actively working in restoring the service.
Posted Dec 09, 2025 - 12:59 UTC
This incident affected: Grafana Cloud: Loki (AWS Germany - prod-eu-west-2).