Google Cloud Monitoring data source degraded performance in prod-us-central-0

Incident Report for Grafana Cloud

Resolved

We continue to observe a continued period of recovery. At this time, we are considering this issue resolved. No further updates.
Posted Sep 24, 2025 - 21:06 UTC

Monitoring

We have identified a potential fix, rolled it out, and are monitoring things to ensure the issue is mitigated.
Posted Sep 24, 2025 - 20:07 UTC

Investigating

We are currently seeing degraded performance in prod-us-central-0 for the Google Cloud Monitoring data source. We are currently investigating this issue.
Posted Sep 24, 2025 - 16:26 UTC
This incident affected: Grafana Cloud: Hosted Grafana (GCP US Central - prod-us-central-0).