Some Alert Rule Evaluations Failing

Incident Report for Grafana Cloud

Resolved

This incident has been resolved.
Posted Feb 24, 2026 - 17:09 UTC

Monitoring

A fix has been implemented, and we are monitoring results.
Posted Feb 24, 2026 - 16:27 UTC

Investigating

We are currently investigating an issue impacting a subset of users in the prod-us-east-0 region. Impacted customers will receive a "failed to execute query" error when evaluating alert rules.
Posted Feb 24, 2026 - 14:31 UTC
This incident affected: Grafana Cloud: Prometheus Rules and Alerts (AWS US East - prod-us-east-0: Rule Evaluation).