Degraded Write Performance on Tempo Metrics Generator

Incident Report for Grafana Cloud

Monitoring

Engineering has released a fix and as of 19:19 UTC, customers should no longer experience degraded write performance. We will continue to monitor for recurrence and provide updates accordingly.
Posted Jun 20, 2025 - 19:20 UTC

Investigating

As of 15:03 UTC, we identified an issue causing degraded write performance in the Tempo Metrics Generator. Affected users may experience dropped spans in remote-written metrics.

Our engineering team is actively investigating, and we will provide updates as more information becomes available.
Posted Jun 20, 2025 - 16:26 UTC
This incident affects: Grafana Cloud: Tempo (AWS US East - prod-us-east-0: Metrics Generator).