Hosted Grafana - Connection Errors and Slow Load Times

Incident Report for Grafana Cloud

Resolved

We continue to observe a period of stability. At this time, we are considering this issue resolved.
Posted Sep 10, 2025 - 22:13 UTC

Monitoring

Engineering has released a fix and customers should no longer experience loading or connection issues. We will continue to monitor for recurrence and provide updates accordingly.
Posted Sep 10, 2025 - 22:00 UTC

Investigating

As of 21:00 UTC, we detected an issue affecting Hosted Grafana instances in a single region. Impacted users may experience slow load times or connection errors when accessing their instances.

Our Engineering team is actively investigating, and we’ll provide updates as they become available.
Posted Sep 10, 2025 - 21:47 UTC
This incident affected: Grafana Cloud: Hosted Grafana (AWS US West - prod-us-west-0).