Mimir Write Performance Degradation

Incident Report for Grafana Cloud

Resolved

This incident has been resolved. Thank you for your patience.
Posted Jul 14, 2026 - 22:00 UTC

Monitoring

From 19:24 until 19:40 UTC, backend performance degradation impacted ingestion.  We are currently monitoring.
Posted Jul 14, 2026 - 20:28 UTC
This incident affected: Metrics (GCP US Central - prod-us-central-0: Ingestion).