Write failures in prod-eu-west-0

Incident Report for Grafana Cloud

Resolved

We continue to observe a continued period of recovery. At this time, we are considering this issue resolved. No further updates.
Posted Mar 05, 2026 - 23:36 UTC

Monitoring

Engineering has released a fix and as of 22:00 UTC, customers should no longer experience write failures and delays in rule evaluation.

We will continue to monitor for recurrence and provide updates accordingly.
Posted Mar 05, 2026 - 22:41 UTC

Investigating

A recent incident affecting the data read path and rule execution within prod-eu-west-0 began at ~21:05 UTC on March 5, 2026. Customers with instances in this region may experience write failures and delays in rule evaluation.

Engineering is actively engaged and assessing the issue. We will provide updates accordingly.
Posted Mar 05, 2026 - 22:27 UTC
This incident affected: Grafana Cloud: Prometheus (GCP Belgium - prod-eu-west-0: Querying, GCP Belgium - prod-eu-west-0: Ingestion).