Query degradation and possible rule evaluation failure on prod-eu-west-0.cortex-prod-01

Incident Report for Grafana Cloud

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 01, 2026 - 10:12 UTC

Update

We are continuing to investigate this issue.
Posted Apr 01, 2026 - 10:11 UTC

Investigating

We are currently observing delays in ingesting data, possibly causing partial query results and failed rule evaluations for prod-eu-west-0.cortex-prod-01 metrics cell.
Posted Apr 01, 2026 - 09:56 UTC
This incident affects: Grafana Cloud: Prometheus (GCP Belgium - prod-eu-west-0: Querying, GCP Belgium - prod-eu-west-0: Ingestion).