Some Reports of Grafana Not Loading.

Incident Report for Grafana Cloud

Resolved

This incident has been resolved. Thank you for your patience.
Posted Jul 15, 2026 - 21:00 UTC

Update

The fix is in the process of being rolled out.
Posted Jul 15, 2026 - 20:50 UTC

Identified

We believe we have found the cause and are working on remediation. It is also worth mentioning that only stacks on the "slow" release channel are impacted.
Posted Jul 15, 2026 - 18:47 UTC

Investigating

We are currently investigating an issue impacting a small subset of stacks in the impacted regions. We will provide more details as they become available.
Posted Jul 15, 2026 - 18:07 UTC
This incident affected: Grafana (AWS US East - prod-us-east-0, GCP US Central - prod-us-central-0, GCP US Central - prod-us-central-3, GCP US Central - prod-us-central-4).