IRM Access Issues for a Small Group of Users

Incident Report for Grafana Cloud

Update

The fix has been deployed to the majority of deployments. We continue to monitor progress.
Posted Sep 22, 2026 - 18:57 UTC

Monitoring

A fix is currently being rolled out and will be deployed progressively over the next few hours. We appreciate your patience as this reaches all affected customers.
Posted Sep 22, 2026 - 17:19 UTC

Identified

The issue has been identified, and we are working on a fix.
Posted Sep 22, 2026 - 15:55 UTC

Investigating

We are currently investigating an issue that may cause a small group of users to experience unexpected IRM access issues, or undelivered pages. Most users should not be affected.
Posted Sep 22, 2026 - 14:57 UTC
This incident affects: Incident Management and Response (IRM).