Metrics Aggregation - Degraded Performance

Incident Report for Grafana Cloud

Resolved

This incident has been resolved.
Posted Sep 13, 2025 - 00:01 UTC

Investigating

As of 16:00 UTC, we became aware of an issue with a metrics aggregation. Users impacted may encounter metrics aggregation delays/degraded performance.

Engineering is actively engaged and assessing the issue. We will provide updates accordingly.
Posted Sep 12, 2025 - 18:51 UTC
This incident affected: Grafana Cloud: Prometheus (GCP US Central - prod-us-central-0: Querying).