Service degradation on Logs Read path in AWS US West (us-west-0)

Incident Report for Grafana Cloud

Resolved

This incident has been resolved.
Posted Mar 10, 2026 - 20:39 UTC

Identified

There has been a reoccurrence o the issues on the Read path of Loki services on AWS US West since yesterday 9th around ~17:15UTC.
The issue has been identified, and resolutions steps has been taken to restore full service. We are currently monitoring the service status.

The impact of this includes timeouts and 5xx errors when query logs for customers on this cluster.
Posted Mar 10, 2026 - 15:26 UTC
This incident affected: Grafana Cloud: Loki (AWS US West - prod-us-west-0).