InfluxDB-backed Dashboard Variables Experiencing Issues
Incident Report for Grafana Cloud
Resolved
This incident has been resolved.
Posted Feb 23, 2023 - 23:45 UTC
Monitoring
Engineering has identified a forward correction for the InfluxDB dashboard variable issue and released the change via a new version of Grafana v.9.4.1 to affected Cloud accounts. All InfluxDB dashboard variables should now be functioning as expected.

To ensure the integrity of this correction, we are monitoring the state of this release for 60 minutes, after which we will consider this issue resolved.
Posted Feb 23, 2023 - 22:44 UTC
Identified
Engineering has initiated a rollback to Grafana Cloud v.9.3.6 to provide immediate relief and restore InfluxDB-backed dashboard functionality. We will continue to pursue root cause and a long term resolution.

We will continue to provide updates as more information is shared.
Posted Feb 23, 2023 - 17:09 UTC
Investigating
As of 15:30 UTC today, we were alerted to an issue surrounding dashboard variables for dashboards making use of InfluxDB as the datasource and running Grafana version 9.4.1. Users encountering this issue will experience the following error on InfluxDB-backed dashboards:
"Error updating options: Cannot destructure property '__interval' of 't' as it is undefined."

Engineering is aware and actively investigating both root cause and a forward path. We will continue to provide updates as information is shared.
Posted Feb 23, 2023 - 16:52 UTC