K6 - Test run metrics processing is delayed

Incident Report for Grafana Cloud

Update

We've improved the metric ingestion delay time and are working on additional fixes to bring it down to expected range. Customers can currently expect a delay of 2 to 5 minutes before their test run metrics show up (after starting a test).
Posted Jun 26, 2026 - 23:30 UTC

Update

Update: Changed incident title to "Test run metrics processing is delayed"

We have found the issue and are working on deploying the fix.
Posted Jun 26, 2026 - 16:33 UTC

Update

We are experiencing intermittent delays with secondary metrics processing for k6 Cloud test runs due to heavy load. We don't expect any data loss or impact on user runs, but results may take longer time to appear in UI.
Posted Jun 26, 2026 - 14:09 UTC

Update

A small update: The issue is isolated to new test runs, and users can go see the metrics of all the previous test runs
Posted Jun 26, 2026 - 13:19 UTC

Investigating

We’re currently investigating an issue causing metrics not to appear during test runs. . Our team is actively working to identify the cause. Thank you for your patience.
Posted Jun 26, 2026 - 13:08 UTC
This incident affects: Performance and Load Testing (Cloud Test Runs, Result Analysis).