Various Datasource Issues

Incident Report for Grafana Cloud

Resolved

This incident has been resolved.
Posted Mar 19, 2026 - 18:44 UTC

Update

We are continuing to monitor for any further issues.
Posted Mar 19, 2026 - 17:56 UTC

Update

We have observed recovery for the Cloudwatch Datasource.

We are now seeing failures for the following Datasources:

Aurora
Opensearch
X-Ray
Timestream
Redshift
Sitewise

A fix for the above is being rolled out now, and we will monitor progress.

We will also change the name of this incident from "Cloudwatch Datasource Issues" to "Various Datasource Issues" to more accurately reflect impact.
Posted Mar 19, 2026 - 17:56 UTC

Monitoring

We have identified the issue, and are rolling out the fix. We are already seeing improvements and will continue to monitor progress.
Posted Mar 19, 2026 - 17:13 UTC

Investigating

We are currently investigating an issue impacting the CloudWatch Datasource causing failures.
Posted Mar 19, 2026 - 16:46 UTC
This incident affected: Grafana Cloud: Integrations.