PDC-Prod-eu-west-2 cluster degraded performance

Incident Report for Grafana Cloud

Resolved

This incident has been resolved.
Posted Nov 17, 2025 - 12:23 UTC

Monitoring

Engineering has released a fix and as of 12:15 UTC, customers should no longer experience performance degradation on the PDC service. We will continue to monitor for recurrence and provide updates accordingly.
Posted Nov 17, 2025 - 12:22 UTC

Investigating

We are currently facing performance degradation on PDC service hosted on prod-eu-west-2 cluster. Our Engineering Team is currently working on fixing the issue, we do apologize for any inconvenience.
Posted Nov 17, 2025 - 11:56 UTC
This incident affected: Grafana Cloud: Private Datasource Connect (PDC) (AWS Germany - prod-eu-west-2).