Frontend Observability - Suspected commit feature not working as expected

Incident Report for Grafana Cloud

Resolved

A fix has been deployed and the issue after monitoring as been fixed.
Posted Jun 18, 2026 - 10:13 UTC

Investigating

We’re currently investigating an issue affecting Frontend Observability product. The "Suspected commit" feature is not currently working as expected. Ingestion and querying is unaffected by this. Our team has identified the cause and is actively working on a fix. Thank you for your patience.
Posted Jun 18, 2026 - 08:48 UTC
This incident affected: Frontend Observability (AWS Germany - prod-eu-west-2, AWS US East - prod-us-east-0, AWS US West - prod-us-west-0).