Intermittent Errors and High latency Writing to Cloud Metrics, Cloud Logs and Cloud Traces

Incident Report for Grafana Cloud

Resolved

We continue to observe an extended period of recovery and we're marking the incident as resolved at this point in time.
Posted May 14, 2026 - 07:06 UTC

Update

We continue to see signs of recovery and improved stability across impacted services. Our teams continue to closely monitor the situation while working with the cloud provider.
Posted May 13, 2026 - 21:10 UTC

Update

We continue to see signs of recovery and improved stability across impacted services. Our teams continue to closely monitor the situation while working with the cloud provider.
Posted May 13, 2026 - 15:41 UTC

Monitoring

We are seeing signs of recovery and improved stability across impacted services over the past hour. Our teams continue to closely monitor the situation while working with the cloud provider.
Posted May 13, 2026 - 13:37 UTC

Update

We have identified expanded impact affecting Grafana Cloud Logs and Grafana Cloud Traces in addition to Cloud Metrics, causing intermittent errors and increased latency when writing data. Our teams continue working on a fix and investigating the issue with the cloud provider’s support team.
Posted May 13, 2026 - 10:25 UTC

Update

We’re continuing to investigate the issue causing intermittent errors and high latency when writing to Cloud Metrics. We are in contact with the cloud provider’s support team, and they are investigating the issue alongside us.
Posted May 13, 2026 - 10:01 UTC

Investigating

We’re currently investigating an issue causing intermittent errors and high latency when writing to Cloud Metrics. Our team is actively working to identify the cause. Thank you for your patience.
Posted May 13, 2026 - 08:50 UTC
This incident affected: Grafana Cloud: Loki (GCP US Central - prod-us-central-0, GCP US Central - prod-us-central-5), Grafana Cloud: Prometheus (GCP US Central - prod-us-central-0: Ingestion, GCP US Central - prod-us-central-5: Ingestion), and Grafana Cloud: Tempo (GCP US Central - prod-us-central-0: Ingestion).