Longer Than Expected Load Times on Grafana Cloud

Incident Report for Grafana Cloud

Resolved

We continue to observe a continued period of recovery. At this time, we are considering this issue resolved. No further updates.
Posted Nov 22, 2025 - 17:06 UTC

Monitoring

A fix has been implemented, and we are seeing latency down across clusters. We are continuing to monitor progress.
Posted Nov 21, 2025 - 17:04 UTC

Investigating

We are currently investigating reports of long load times on Grafana Cloud. We will update as more information becomes available.
Posted Nov 21, 2025 - 15:47 UTC