The incident is resolved. We are in contact with customers affected by this change.
Posted Jan 22, 2026 - 22:29 UTC
Identified
During the secrets migration in https://status.grafana.com/incidents/47d1q4sphrmj, secrets proxy URLs for some customers updated in the following regions: prod-us-central-0, prod-us-east-0, and prod-eu-west-2. This was an unexpected breaking change affecting a subset of customers.
This will specifically affect customers who are using secrets on private probes behind a firewall.
We are investigating. If your private probes are impacted, we ask you to update firewall rules for the secrets proxy to allow outbound connections to the updated hosts:
Note that this URL change affects only a small subset of customers, the majority of customers will not need to update firewall rules. For affected customers, private probes will show the following error in probe logs, for example: Error during test execution: failed to get secret: Get "https://gsm-proxy-prod-us-east-2.grafana.net/api/v1/secrets/.../decrypt": Forbidden undefined
Posted Jan 21, 2026 - 21:16 UTC
This incident affected: Grafana Cloud: Synthetic Monitoring (AWS Germany - prod-eu-west-2: API, AWS US East - prod-us-east-0: API, GCP US Central - prod-us-central-0: API).